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Quartus Prime Lite Version 17.0 Tutorial 
Created September 10, 2014;  Last Updated July 17, 2020 

 

This tutorial will walk you through the process of developing circuit designs within Quartus, simulating 

with Modelsim, and downloading designs to the DE1-SoC board.   

 

 [0]  Installing the Quartus Software 

Most of the designs in this class will be done through the Altera Quartus software.  This is preloaded on 

machines in the CSE 003 lab and you are welcome to do all the work on these PCs.  However, if you have 

a PC of your own (or Windows VM) that you would like to use, you can install the software there as well. 

 

1) Download the Quartus 17.0 software from the CSE369 website.  You’ll need the Quartus and 

ModelSim install files and the CycloneV  file.  Save all of these to the same directory. 

2) Run the  executable (this is slow to start up).  When it asks for 

components to install, select all of the following:  “Quartus Prime,” “Devices→Cyclone V,” and 

“ModelSim – Intel FPGA Starter Edition.”  When the software is done installing (the last dialog 

box), make sure to select “Launch USB Blaster II driver installation.” 

3) Start the Quartus software.  When it asks about licensing, select “Run the Quartus Prime 

software.”  You will likely have to start it twice to get it to run the first time. 

[1]  File Setup for CSE369 

For each lab in this class, we will create multiple files for your designs, for testing, and for downloading 

to the DE1-SoC board.  To keep things sane, we suggest creating subdirectories for each lab within a 

class directory: create a cse369 directory and then create a lab1 subdirectory for Lab 1.  If you are using 

the lab machines, put your work onto your Z: drive (shared across all machines – it should be the drive 

with your NetID on it). 

Download  from the course website and unzip the files into the subdirectory you 

just created.  These files will help you get started quickly with Quartus. 

 

 

The steps we show you here will be used throughout the class, so take notes and refer back to 

the appropriate sections when you are working on future labs. 

If you do not want to install Quartus on your own machine, skip to the next section. 

Do not reuse the same directory for different labs, because you will want to refer back to a 

working design when you develop each new lab. 

When you start each lab after Lab 1, copy the previous directory over as the new directory so 

that you can reuse many of the files and the setup you did in previous labs. 
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 [2]  Creating Verilog Files in Quartus 

The initial Lab 1 files set up a Quartus project, but now we need to add some actual “circuitry.” 

We will create a simple design of a 2:1 MUX – this is a device with two data inputs  and , and a 

select input .  The output is equal to the  input when , and the output is equal to the  

input when .  

1) Start Quartus II by double-clicking on the  file. 

 

2) Create a SystemVerilog file.  Go to File→New, select “SystemVerilog HDL File”, and hit “OK” 

(Figure 1).  You will do this whenever you want to create a new Verilog file. 

 

3) Name the file.  The new file is opened for you in Quartus’ text editor, but doesn’t have a name 

yet.  Go to File→Save As and give it the name  (Figure 2).  You should notice that the 

title bar for the editor pane has now changed. 

 

4) Populate the file.  Type in the code found in Figure 3 (or just cut-and-paste it in) to .  

This creates the module we are developing (“ ”), as well as a tester module 

(“ ”) that will help us check whether the design is correct. 

 
Figure 1:  Creating a new Verilog file in 

Quartus 
 

Figure 2:  Saving and naming Verilog files in Quartus. 

 

Your PC may hide the file extension, so if you just see “ ”, hover over the file and make 

sure the pop-up information text says “QPF File.” 

System Verilog is “modern” Verilog, with a lot of nice features over previous versions of Verilog. 

We will use System Verilog exclusively in this class. 

In Verilog, the filename must be the same as the module you are designing. 
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Figure 3:  Code for mux2_1.sv 

[3]  Synthesizing a Design 

Now that we have the design created in Quartus, we need to check that it is valid Verilog:   

1) Set the “top-level” design.  As we go through the class, we will create designs with many 

different modules all talking to one-another; Quartus needs to know which of the files holds the 

top-level, complete design.  In the upper-left side of Quartus is the “Project Navigator.”  Select 

“Files” in the drop-down menu to the right of the Project Navigator.  Right-click on the file 

“ ,” then select “Set as Top-Level Entity” (Figure 4). 

2) Run Quartus’ Analysis and Synthesis tool.  Look at the top toolbar for the blue checkmark with 

the purple triangle and the tiny gate symbol (Figure 5).  Press that button to have Quartus check 

whether the design is at least syntactically correct. 

3) Fix any syntax errors.  The Analysis and Synthesis tool should run for a little while, and then tell 

you in the message window (near the bottom of Quartus) that “Analysis & Synthesis was 

successful.”  If it does not, then check your design and any error messages found in the message 

window – you can usually double-click on the error message and it will take you to exactly 

where Quartus thinks the error is.  Correct the problems, and re-run Analysis & Synthesis. 

Once Quartus declares success, we know that the file is syntactically correct Verilog.  However, we don’t 

know whether the design is a proper implementation of the desired functionality.  For that, we will 

simulate the design, which uses the ModelSim simulator to show the actual behavior of our design. 
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Figure 4 (left):  Setting the top-level file in a Quartus project. 

 

 

 

 

 

Figure 5 (below):  The “Start Analysis & Synthesis” button and where to find it. 

 

[4]  Simulating a Design 

In addition to Quartus II, we will be using the ModelSim software, which can simulate Verilog designs 

before you ever run them on actual hardware.  To help make using the tool easier, we have provided the 

following three files as part of : 

• :  A file to start ModelSim with the correct working directory. 

• :  A command file for ModelSim that will compile your design, set up the windows 

for the design, and start simulation. 

• :  A default file that sets up the simulation window. 

1) Start ModelSim by double-clicking .  This should show a blue title 

screen before the ModelSim opens. 

 

2) Simulate the circuit by issuing the command “ ” in the Transcript pane.  The 

Transcript pane can be found at the bottom of the ModelSim window (Figure 6).  The 

 file will compile and run the simulation for . 

 

If you instead saw a black window flash by and nothing happened, then your ModelSim is 

installed at a non-standard location; edit the  file and put in the 

correct path to the  executable.  Save the file and retry starting ModelSim. 

The path you enter should resemble the following:  

 

If your path shows “ ”, modify it to be “ ” instead. 

Hitting <Tab> when you have typed “ ” will auto-complete with the full command, since 

there are no other files in the Lab 1 directory that start with “ ”. 
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3) View the results in the Wave pane (Figure 7).  Time moves from left (start) to right (end), with a 

green line for each input and output of the design.  When the green line is up, it means that 

signal is true; when the green line is down, it means the signal is false.   

 

 

 

 
Figure 6:  Entered the command " " into the Transcript pane.  Press <Enter> to issue the command. 

 
Figure 7:  Simulation results shown in the Wave pane. 

Any red or blue lines indicate that there is a problem in your Verilog files; check that you have 

done all of the previous steps correctly. 
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[5]  Navigating the Simulation  

The initial waveforms are rather hard to see, so let’s explore the navigation options in ModelSim: 

 

• Use the Zoom commands:  Found in the toolbars near the top of ModelSim. 

 

Use the left two commands (+ and – magnifying glass) to zoom so that the green waves fill the 

Wave pane.  Notice that the scrollbar at the bottom now becomes useful, allowing us to move 

around in the simulation.  The time for each horizontal position is shown at the bottom.  The 

third button (black-filled magnifying glass) zooms to fit the entire waveform in the window. 

• View signal values in the Msgs column:  Left-click anywhere within the waveform viewer (the 

part with the black background) to move the cursor, which is the yellow vertical line with the 

time in yellow at the bottom (Figure 8).  The Msgs column will update with the signal values at 

the time specified by the cursor (Figure 9). 

 

• Use the Wave Cursor commands to jump to points of interest:  Also found in the toolbars near 

the top of ModelSim.  To be usable, a single signal must be selected/highlighted (either click on 

a signal name or somewhere on the green waveform for that signal). 

 

Select the  signal and play with the six cursor movement commands to see what they do. 

 
Figure 8:  You can move the cursor (yellow line) within the 
waveform viewer (black background) of the Wave pane. 

 
Figure 9:  The values in the Msgs column will automatically 

update as you move the cursor. 

 

Many of the following commands will only be usable if the Wave pane is selected.  If you don’t 

see the Wave pane or ever accidentally close it, go to View→Wave to re-open it. 

The signal values you will see are , ,  (“strong 0”), and  (“strong 1”).  For the purposes 

of this class,  and  are equivalent to  and , respectively. 
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[6]  Saving the Simulation View 

Once we have adjusted our simulation view to better display our design results, we will often want to 

save these settings into a file so our next simulation run will return to this Wave pane setup. 

1) Make sure that the Wave pane is active by clicking anywhere within it (signal list, Msgs column, 

or waveform viewer). 

2) Select File→Save Format or press Control-S. 

3) Overwrite the file .  In general, we will use the format file naming convention 

of . 

4) [optional]  Verify the new format file by issuing the command “ ” again from the 

Transcript pane. 

Now when you re-run your simulation, even after changing the Verilog files, it will have the Wave pane 

set up exactly the way we left it! 

[7]  More Complex Designs – Create a 4:1 MUX 

The 2:1 MUX is a simple, single-file design to get you started.  But real designs will have multiple files 

and won’t have all the scripts set up for you.  Here we will show you how to build a new, more complex 

design that will demonstrate how to work with the various ModelSim support files. 

1) Add , which uses  as a submodule and has its own testbench, by either: 

a. Downloading the file from the “Files→Labs→Lab 1” page of the course website into your Lab 

1 directory, then open the file in Quartus and select Project→“Add Current Project to File.” 

b. Creating a new SystemVerilog HDL file and either type or cut-and-paste the code found in 

Figure 10, and save it as . 

 

2) Set  as the top-level entity and run the Analysis & Synthesis tool.  Fix errors as 

necessary until successful. 

  

Every Verilog module should have a testbench, because the quickest way to get a working 

design is to test each submodule as you write it. 
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Figure 10:  Code for mux4_1.sv 

[7a]  More Complex Designs – ModelSim Command File 

Before we can simulate, we need to modify  for the new design.  In the text editor of your 

choice (e.g., WordPad, Notepad), open  and make the following modifications (Figure 11): 

1) Add   to the compilation section.  For all Quartus designs, you will have 

one “ ” line for each Verilog file in your design. 

2) Edit the “ ” line to end with  instead of  to 

change the module being simulated/tested. 

3) Edit the “ ” line to end with  instead of  to change the 

waveform settings.  Each module should have its own  file, so that during debugging 

of a large project you can switch between different modules to test. 

Save , run  in the lab1 directory, then execute “ ”. 

The system should start simulating, show the waveform pane, and then give an error that it cannot open 

the macro file .  That’s because we haven’t provided the waveform file for you; you 

need to create it yourself! 
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Figure 11:  The three modifications: (1) add file to compile, (2) change testbench to simulate, and (3) change waveform settings. 

[7b]  More Complex Designs – ModelSim Waveform Macro 

Our goal is to get the Wave pane properly set up so we can save the waveform settings as a  

file. 

1) Locate the sim tab (confusingly opened via View→Structure), which may be hidden behind the 

“Library” or “Project” tabs on the left side of ModelSim.  This tab shows the various modules in 

the design. 

2)  is the top-level design, which contains  (“device under test”), the 

name of the  module we are testing.  Clicking on the plus next to  shows the three 

’s inside of the :  , , and .  If you click on any of the units in the sim tab, the 

Objects pane next to it shows the signals inside that module (Figure 12). 

3) Click on  in the sim tab, select all of the signals in the Objects pane except 

, and drag-and-drop them into the Wave pane.   

4) Save the waveform as  to create the missing file for simulation. 

5) Re-run “ ” from the Transcript pane to get a simulation of the entire design. 

Examine the waveforms using the navigation techniques.  Figure out what the  module actually 

does. 
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Figure 12:  The sim tab is found on the far-left and contains all of the modules in this design.  Selecting a module or submodule 
will show all of the signals contained in that module in the Objects pane just to the right. 

[8]  Process Recap 

You now have the commands necessary to develop new designs, commands you will use for all future 

labs.  Just to make sure you’ve got it, here’s a cheat-sheet of the steps for future Verilog designs: 

1) Make a copy of a previous lab directory to build off of what you already have (Quartus project 

file, ModelSim files) while keeping the old design as a reference. 

2) For each module you need to write: 

a) Create a new file, write the module definition, and write a testbench for that module. 

b) Set the testbench as the top-level module in Quartus. 

c) Run Analysis and Synthesis and fix any errors it finds. 

d) Edit  to include the new module. 

e) Start ModelSim and perform “ .”  Fix any errors the compiler finds. 

f) When it complains about a missing  file, set up the Wave pane by drag-and-

dropping signals from the Object pane.  Save the waveform setup using File→“Save 

Formatting”, then perform “ ” again. 

g) Check the simulation results, correct errors, and iterate until the module works. 

This process has two major features:  First, it has you test every module before you work on the larger 

modules that call this unit.  This will significantly simplify the design process.  Second, you have a 

separate  file for each Verilog file.  This keeps a formatted test window for each module, 

which can help when you discover a fresh bug in a larger design later on.  You can always go back and 

test a submodule by simply editing the  file to point to the testbench and  file for 

the unit you want to test. 
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[9]  Mapping a Design to the FPGA Hardware 

So far we have developed and tested a design completely in software.  Once it is working, it is time to 

use Quartus II to convert that design into a form that can actually be loaded onto the FPGA. 

To use the switches, lights, and buttons on the DE1 board, we need to hook up the connections of the 

circuit design to the proper inputs and outputs of the FPGA.   

Download the file  from the Files→Labs→“Lab 1” page of the course website into your lab1 

folder, add it to your project, then set it as the top-level entity. 

We now need to compile the design into a bitfile, a file that can be downloaded to the FPGA.  To do 

that, we press the “Start Compilation” button just to the left of the “Analysis & Synthesis” button we 

have used before:  

This will run the multiple steps necessary to compile the design.  You can watch the progress of the 

compilation in the Tasks pane in the lower-left of Quartus. 

[10]  Configuring the FPGA with the Bitfile 

We now need to send the bitfile to the DE1-SoC. 

1) Connect the DE1-SoC to wall power with the power cord. 

2) Make sure that the board is off (i.e., the board should not light up when you plug it in), then 

connect the board to your computer’s USB.  You can then turn on the DE1-SoC. 

3) In Quartus, go to File→Open.  In the “Files of type” box at bottom, select “Programming Files 

(*.cdf …” and then double-click on  (Figure 13). 

4) This will bring up the Programmer dialog box (Figure 14). 

a) If the “Start” button is active, proceed to the next step. 

b) If the “Start” button is greyed out, you need to first run click the “Hardware Setup…” button.  

This will bring up the “Hardware Setup” dialog box.  Set “Currently selected hardware” to 

“DE-SoC”, and close the dialog box (Figure 15). 

5) Click the “Start” button and the DE1 board will be programmed – you’re done! 

 

 

 

 

When you are developing a design, you can keep the Programmer dialog box open so that you 

can download the design multiple times, including after changing the input files and recompiling 

the design. 
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Figure 13:  Open the chain description file (.cdf) to program the DE1-SoC 

 
Figure 14:  Programmer dialog box with the “Start” and “Hardware Setup…” buttons highlighted. 

 
Figure 15:  Hardware Setup dialog box in case the “Start” button in the Programmer dialog box was greyed out. 
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[11]  Appendix A:  Files in the Default Project 

For those who are interested, here are what each of the files contained in  do: 

Filename Purpose 

Quartus project file.  Top-level that groups all the information together.  
Preconfigured for the DE1-SoC board. 

Sets up the pin assignments, which connects the signals of the user design 
to specific pins on the FPGA. 

Tells Quartus about the timing of various signals. 

Tells Quartus to not print some useless warning messages. 

Simple batch file – starts ModelSim in the current directory. 

Sets up the waveform viewer for the first design. 

Programmer file, tells Quartus how to download designs to the DE1. 

ModelSim .do file – compiles and simulates the design. 

 

  


